Input validation error in Linux kernel - CVE-2009-4538

 

Input validation error in Linux kernel - CVE-2009-4538

Published: January 12, 2010 / Updated: November 16, 2018


Vulnerability identifier: #VU94168
CSH Severity: High
CVSS v4: 9.3 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2009-4538
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

drivers/net/e1000e/netdev.c in the e1000e driver in the Linux kernel 2.6.32.3 and earlier does not properly check the size of an Ethernet frame that exceeds the MTU, which allows remote attackers to have an unspecified impact via crafted packets, a related issue to CVE-2009-4537.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux (Ubuntu package)

How to mitigate CVE-2009-4538

Install update from vendor's website.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-55.82
linux (Ubuntu package) - addressed in versions 2.6.24-27.65, 2.6.27-17.45, 2.6.28-18.59, 2.6.31-19.56

External References

Related Security Bulletins