Incorrect default permissions in Linux kernel - CVE-2007-4308

 

Incorrect default permissions in Linux kernel - CVE-2007-4308

Published: August 14, 2007 / Updated: October 15, 2018


Vulnerability identifier: #VU94800
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2007-4308
CWE-ID: CWE-276
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to perform service disruption.

The (1) aac_cfg_open and (2) aac_compat_ioctl functions in the SCSI layer ioctl path in aacraid in the Linux kernel before 2.6.23-rc2 do not check permissions for ioctls, which might allow local users to cause a denial of service or gain privileges.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.17 (Ubuntu package)
linux-source-2.6.20 (Ubuntu package)

How to mitigate CVE-2007-4308

Install update from vendor's repository.

linux-source-2.6.17 (Ubuntu package) - update to 2.6.17.1-12.40
linux-source-2.6.20 (Ubuntu package) - update to 2.6.20-16.31

External References

Related Security Bulletins