Improper authentication in Linux kernel - CVE-2008-4576
Published: October 15, 2008 / Updated: September 29, 2017
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.
sctp in Linux kernel before 2.6.25.18 allows remote attackers to cause a denial of service (OOPS) via an INIT-ACK that states the peer does not support AUTH, which causes the sctp_process_init function to clean up active transports and triggers the OOPS when the T1-Init timer expires.
Affected software
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux-backports-modules-2.6.15 (Ubuntu package)
linux-restricted-modules-2.6.15 (Ubuntu package)
linux-ubuntu-modules-2.6.22 (Ubuntu package)
linux-source-2.6.22 (Ubuntu package)
linux-backports-modules-2.6.22 (Ubuntu package)
linux-restricted-modules-2.6.22 (Ubuntu package)
linux (Ubuntu package)
linux-ubuntu-modules-2.6.24 (Ubuntu package)
linux-backports-modules-2.6.24 (Ubuntu package)
linux-restricted-modules-2.6.24 (Ubuntu package)
linux-restricted-modules (Ubuntu package)
linux-backports-modules-2.6.27 (Ubuntu package)
How to mitigate CVE-2008-4576
linux-backports-modules-2.6.15 (Ubuntu package) - update to 2.6.15-53.11
linux-restricted-modules-2.6.15 (Ubuntu package) - update to 2.6.15.12-53.4
linux-ubuntu-modules-2.6.22 (Ubuntu package) - update to 2.6.22-16.41
linux-source-2.6.22 (Ubuntu package) - update to 2.6.22-16.60
linux-backports-modules-2.6.22 (Ubuntu package) - update to 2.6.22-16.17
linux-restricted-modules-2.6.22 (Ubuntu package) - update to 2.6.22.4-16.12
linux (Ubuntu package) - addressed in versions 2.6.24-22.45, 2.6.27-9.19
linux-ubuntu-modules-2.6.24 (Ubuntu package) - update to 2.6.24-22.35
linux-backports-modules-2.6.24 (Ubuntu package) - update to 2.6.24-22.29
linux-restricted-modules-2.6.24 (Ubuntu package) - update to 2.6.24.14-22.53
linux-restricted-modules (Ubuntu package) - update to 2.6.27-9.13
linux-backports-modules-2.6.27 (Ubuntu package) - update to 2.6.27-9.5
External References
- http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.25.18
- http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00001.html
- http://permalink.gmane.org/gmane.comp.security.oss.general/1039
- http://secunia.com/advisories/32370
- http://secunia.com/advisories/32386
- http://secunia.com/advisories/32759
- http://secunia.com/advisories/32918
- http://secunia.com/advisories/32998
- http://secunia.com/advisories/33180
- http://secunia.com/advisories/33182
- http://secunia.com/advisories/33586
- http://www.debian.org/security/2008/dsa-1681
- http://www.debian.org/security/2008/dsa-1687
- http://www.gossamer-threads.com/lists/linux/kernel/981012?page=last
- http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-2.6.27-rc6-git6.log
- http://www.redhat.com/support/errata/RHSA-2008-1017.html
- http://www.redhat.com/support/errata/RHSA-2009-0009.html
- http://www.securityfocus.com/bid/31634
- http://www.ubuntu.com/usn/usn-679-1
- https://exchange.xforce.ibmcloud.com/vulnerabilities/45773
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9822
- https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00689.html
- https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00693.html