Improper control of generation of code ('code injection') in Linux kernel - CVE-2008-0600

 

Improper control of generation of code ('code injection') in Linux kernel - CVE-2008-0600

Published: February 12, 2008 / Updated: February 13, 2023


Vulnerability identifier: #VU95209
CSH Severity: Low
CVSS v4: 8.5 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2008-0600
CWE-ID: CWE-94
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to execute arbitrary code.

The vmsplice_to_pipe function in Linux kernel 2.6.17 through 2.6.24.1 does not validate a certain userspace pointer before dereference, which allows local users to gain root privileges via crafted arguments in a vmsplice system call, a different vulnerability than CVE-2008-0009 and CVE-2008-0010.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.17 (Ubuntu package)
linux-source-2.6.20 (Ubuntu package)
linux-source-2.6.22 (Ubuntu package)

How to mitigate CVE-2008-0600

Install update from vendor's repository.

linux-source-2.6.17 (Ubuntu package) - update to 2.6.17.1-12.44
linux-source-2.6.20 (Ubuntu package) - update to 2.6.20-16.35
linux-source-2.6.22 (Ubuntu package) - update to 2.6.22-14.52

External References

Related Security Bulletins