Security restrictions bypass in Linux kernel - CVE-2011-4127

 

Security restrictions bypass in Linux kernel - CVE-2011-4127

Published: July 3, 2012 / Updated: February 13, 2023


Vulnerability identifier: #VU95724
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-4127
CWE-ID: CWE-264
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to read and manipulate data.

The Linux kernel before 3.2.2 does not properly restrict SG_IO ioctl calls, which allows local users to bypass intended restrictions on disk read and write operations by sending a SCSI command to (1) a partition block device or (2) an LVM volume.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)

How to mitigate CVE-2011-4127

Install update from vendor's repository.

linux (Ubuntu package) - update to 3.0.0-16.29

External References

Related Security Bulletins