Security restrictions bypass in Linux kernel - CVE-2010-0291

 

Security restrictions bypass in Linux kernel - CVE-2010-0291

Published: February 15, 2010 / Updated: February 13, 2023


Vulnerability identifier: #VU95729
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2010-0291
CWE-ID: CWE-264
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to read and manipulate data.

The Linux kernel before 2.6.32.4 allows local users to gain privileges or cause a denial of service (panic) by calling the (1) mmap or (2) mremap function, aka the 'do_mremap() mess' or 'mremap/mmap mess.'


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux (Ubuntu package)

How to mitigate CVE-2010-0291

Install update from vendor's repository.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-55.82
linux (Ubuntu package) - addressed in versions 2.6.24-27.65, 2.6.27-17.45, 2.6.28-18.59, 2.6.31-19.56

External References

Related Security Bulletins