Resource management errors in Linux kernel - CVE-2008-0007

 

Resource management errors in Linux kernel - CVE-2008-0007

Published: February 8, 2008 / Updated: October 15, 2018


Vulnerability identifier: #VU95744
CSH Severity: Low
CVSS v4: 8.5 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2008-0007
CWE-ID: CWE-399
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to execute arbitrary code.

Linux kernel before 2.6.22.17, when using certain drivers that register a fault handler that does not perform range checks, allows local users to access kernel memory via an out-of-range offset.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux-backports-modules-2.6.15 (Ubuntu package)
linux-restricted-modules-2.6.15 (Ubuntu package)
linux-source-2.6.20 (Ubuntu package)
linux-backports-modules-2.6.20 (Ubuntu package)
linux-restricted-modules-2.6.20 (Ubuntu package)
linux-source-2.6.22 (Ubuntu package)
linux-ubuntu-modules-2.6.22 (Ubuntu package)
linux-backports-modules-2.6.22 (Ubuntu package)
linux-restricted-modules-2.6.22 (Ubuntu package)

How to mitigate CVE-2008-0007

Install update from vendor's repository.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-52.67
linux-backports-modules-2.6.15 (Ubuntu package) - update to 2.6.15-52.10
linux-restricted-modules-2.6.15 (Ubuntu package) - update to 2.6.15.12-52.3
linux-source-2.6.20 (Ubuntu package) - update to 2.6.20-17.36
linux-backports-modules-2.6.20 (Ubuntu package) - update to 2.6.20-17.12
linux-restricted-modules-2.6.20 (Ubuntu package) - update to 2.6.20.6-17.31
linux-source-2.6.22 (Ubuntu package) - update to 2.6.22-15.54
linux-ubuntu-modules-2.6.22 (Ubuntu package) - update to 2.6.22-15.39
linux-backports-modules-2.6.22 (Ubuntu package) - update to 2.6.22-15.16
linux-restricted-modules-2.6.22 (Ubuntu package) - update to 2.6.22.4-15.11

External References

Related Security Bulletins