#VU11283 Out-of-bounds write


Published: 2018-03-27 | Updated: 2018-07-14

Vulnerability identifier: #VU11283

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2017-15710

CWE-ID: CWE-787

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache HTTP Server
Server applications / Web servers

Vendor: Apache Foundation

Description
The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists in HTTPD mod_authnz_ldap due to improper validation of user-supplied input. A remote attacker can send a specially crafted Accept-Language header value, trigger an out-of-bounds memory write error and potentially cause the target service to crash.

Mitigation
Update to version 2.4.32.

Vulnerable software versions

Apache HTTP Server: 2.4.1 - 2.4.29


CPE

External links
http://httpd.apache.org/security/vulnerabilities_24.html#CVE-2017-15710


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability