#VU11540 Buffer under-read


Published: 2018-04-05

Vulnerability identifier: #VU11540

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-8778

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Ruby
Universal components / Libraries / Scripting languages

Vendor: Ruby

Description
The vulnerability allows a remote attacker to obtain potentially sensitive information on the target system.

The weakness exists in the String#unpack method due to buffer under-read. A remote attacker can gain access to potentially sensitive information.

Mitigation
Update to versions 2.2.10, 2.3.7, 2.4.4 or 2.5.1.

Vulnerable software versions

Ruby: 2.2.0 - 2.6.0-preview1


CPE

External links
http://www.ruby-lang.org/en/news/2018/03/28/buffer-under-read-unpack-cve-2018-8778/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability