#VU12607 Buffer overflow in 389-ds-base


Published: 2018-05-09 | Updated: 2018-05-14

Vulnerability identifier: #VU12607

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2018-1089

CWE-ID: CWE-119

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
389-ds-base
Server applications / Directory software, identity management

Vendor: 389 Directory Server Project

Description

The vulnerability allows a remote unauthenticated attacker to cause DoS condition on the target system.

The weakness exists in ns-slapd due to improper handling of long search filters with characters needing escapes. A remote attacker can submit a specially crafted LDAP request, trigger buffer overflow and cause the service to crash.

Mitigation
Update to versions 1.4.0.9, 1.3.8.1 or 1.3.6.15.

Vulnerable software versions

389-ds-base: 1.4.0 - 1.4.0.8, 1.3.8, 1.3.6 - 1.3.6.14


CPE

External links
http://seclists.org/oss-sec/2018/q2/89


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability