#VU13961 Type confusion in Foxit PDF Reader for Windows and Foxit PDF Editor (formerly Foxit PhantomPDF)


Published: 2018-07-23

Vulnerability identifier: #VU13961

Vulnerability risk: High

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-843

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Foxit PDF Reader for Windows
Client/Desktop applications / Office applications
Foxit PDF Editor (formerly Foxit PhantomPDF)
Client/Desktop applications / Office applications

Vendor: Foxit Software Inc.

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The weakness exists due to type confusion when executing certain JavaScript functions since the application could transform non-XFA-node to XFA-node and use the discrepant XFA-node directly. A remote attacker can trick the victim into opening a specially crafted PDF file and execute arbitrary code with elevated privileges.

Successful exploitation of the vulnerability may result in system compromise.

Mitigation
Update to version 9.2.

Vulnerable software versions

Foxit PDF Reader for Windows: 9.0 - 9.1.0.5096

Foxit PDF Editor (formerly Foxit PhantomPDF): 9.0 - 9.1.0.5096


CPE

External links
http://www.foxitsoftware.com/support/security-bulletins.php


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability