#VU17479 Buffer overflow in Adobe Reader and Adobe Acrobat


Published: 2019-02-12

Vulnerability identifier: #VU17479

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2019-7085

CWE-ID: CWE-119

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Adobe Reader
Client/Desktop applications / Office applications
Adobe Acrobat
Client/Desktop applications / Office applications

Vendor: Adobe

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing PDF files. A remote attacker can create a specially crafted PDF document, trick the victim into opening it, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Adobe Reader: 2019.008.20071 - 2019.010.20069, 2017.009.20044 - 2017.012.20098, 2015.006.30306 - 2015.006.30464

Adobe Acrobat: 2015.006.30306 - 2015.006.30464, 2017.008.30051 - 2017.011.30105


CPE

External links
http://helpx.adobe.com/security/products/acrobat/apsb19-07.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability