#VU18111 Race condition


Published: 2019-04-02

Vulnerability identifier: #VU18111

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-0217

CWE-ID: CWE-362

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache HTTP Server
Server applications / Web servers

Vendor: Apache Foundation

Description

The vulnerability allows a remote authenticated user to impersonate other users.

The vulnerability exists due to a race condition within the mod_auth_digests module. A remote authenticated attacker can send a series of requests and impersonate other users under a threaded MPM.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache HTTP Server: 2.4.0 - 2.4.38


CPE

External links
http://www.apache.org/dist/httpd/CHANGES_2.4


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability