#VU19018 Deserialization of Untrusted Data in jackson-databind


Published: 2019-07-04

Vulnerability identifier: #VU19018

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2019-12384

CWE-ID: CWE-502

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
jackson-databind
Universal components / Libraries / Libraries used by multiple products

Vendor: FasterXML

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to software allows the logback-core class to process polymorphic deserialization. A remote attacker can pass specially crafted data to the application and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

jackson-databind: 2.9.0 - 2.9.8, 2.8.0 - 2.8.11.2, 2.7.0 - 2.7.9.4, 2.6.0 - 2.6.8, 2.5.0 - 2.5.5, 2.4.0 - 2.4.6.1, 2.3.0 - 2.3.5, 2.1.0 - 2.1.4, 2.0.0 - 2.0.4


CPE

External links
http://doyensec.com/research.html
http://github.com/FasterXML/jackson-databind/compare/74b90a4...a977aad
http://lists.debian.org/debian-lts-announce/2019/06/msg00019.html
http://security.netapp.com/advisory/ntap-20190703-0002/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability