#VU19532 Improper privilege management


Published: 2019-07-29 | Updated: 2019-07-29

Vulnerability identifier: #VU19532

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-269

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
ownCloud Server
Web applications / Modules and components for CMS

Vendor: ownCloud

Description

The vulnerability allows a remote attacker to gain elevated privileges.

The vulnerability exists due to the possibility to extend internal-share permissions using the API. A remote attacker can extend the permission of a received subfolder share using the ocs api and gain elevated privileges. Additional risk exists because the privileged extension is also possible on public-shares.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

ownCloud Server: 1.0 - 10.2.0


CPE

External links
http://owncloud.org/security/advisories/possibility-to-extend-internal-share-permissions-using-the-api/
http://github.com/owncloud/core/commit/c93eca49c32428ece03dd67042772d5fa62c8d6e


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability