#VU20100 Out-of-bounds write in Adobe Reader and Adobe Acrobat


Published: 2019-08-13

Vulnerability identifier: #VU20100

Vulnerability risk: High

CVSSv3.1: 7.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-7965

CWE-ID: CWE-787

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Adobe Reader
Client/Desktop applications / Office applications
Adobe Acrobat
Client/Desktop applications / Office applications

Vendor: Adobe

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing PDF files. A remote attacker can create a specially crafted PDF file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Adobe Reader: 2019.008.20071 - 2019.012.20035, 2017.009.20044 - 2017.012.20098, 2015.006.30306 - 2015.006.30498

Adobe Acrobat: 17.009.20044 - 17.012.20098, 15.006.30306 - 15.006.30498


External links
http://helpx.adobe.com/security/products/acrobat/apsb19-41.html


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability