#VU21060 Stack-based buffer overflow


Published: 2019-09-11

Vulnerability identifier: #VU21060

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2019-13485

CWE-ID: CWE-121

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Xymon
Web applications / Remote management & hosting panels

Vendor: GNU

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing a long hostname or service parameter in history.c within the in the history viewer component. A remote authenticated attacker can trigger stack-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Xymon: 4.3.0 - 4.3.28


CPE

External links
http://github.com/svn2github/xymon/blob/master/branches/4.3.28/web/history.c
http://lists.debian.org/debian-lts-announce/2019/08/msg00032.html
http://lists.xymon.com/archive/2019-July/046570.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability