#VU22427 Input validation error


Published: 2019-10-30

Vulnerability identifier: #VU22427

Vulnerability risk: High

CVSSv3.1: 8.3 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-3979

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
MikroTik RouterOS
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor: MikroTik

Description

The vulnerability allows a remote attacker to poison DNS cache.

The vulnerability exists due to insufficient validation of DNS responses, returned by the DNS server. A remote attacker can force the router to make a DNS request to a malicious DNS server and add DNS "A" records for arbitrary domain name to the router's DNS cache. As a result, a remote attacker can force the RouterOS to return incorrect information for DNS requests for arbitrary domain name and redirect all user's traffic to a malicious server.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

MikroTik RouterOS: 6.45 - 6.45.6, 6.44 - 6.44.5


CPE

External links
http://mikrotik.com/download/changelogs#6.45.7
http://www.tenable.com/security/research/tra-2019-46


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability