#VU23182 Information disclosure


Published: 2019-12-02

Vulnerability identifier: #VU23182

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2019-8769

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
WebKitGTK+
Server applications / Frameworks for developing and running applications
WPE WebKit
Server applications / Frameworks for developing and running applications

Vendor: WebKitGTK
WPE WebKit

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to improper input validation in the drawing of web page elements. A remote attacker can reveal browsing history when a victim visit a maliciously crafted website.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

WebKitGTK+: 1.2.0 - 2.25.92

WPE WebKit: 0.1 - 2.25.91


CPE

External links
http://webkitgtk.org/security/WSA-2019-0005.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability