#VU23491 Input validation error


Published: 2019-12-10 | Updated: 2019-12-12

Vulnerability identifier: #VU23491

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2019-1354

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Git
Client/Desktop applications / Software for system administration

Vendor: Git

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of user-supplied input within the Git for Visual Studio. A remote attacker can convince the user to clone a malicious repo and execute arbitrary code on the target system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Git: 2.24.0, 2.23.0, 2.22.0 - 2.22.1, 2.21.0, 2.20.0 - 2.20.1, 2.19.0 - 2.19.2, 2.17.0 - 2.17.2, 2.16.0 - 2.16.5, 2.15.0 - 2.15.3, 2.14.0 - 2.14.5, 2.18.0 - 2.18.1


CPE

External links
http://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1354


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability