#VU23759 Open redirect


Published: 2019-12-20

Vulnerability identifier: #VU23759

Vulnerability risk: Medium

CVSSv3.1: 4.7 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-19915

CWE-ID: CWE-601

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
301 Redirects
Web applications / Modules and components for CMS

Vendor: WebFactory Ltd

Description

The vulnerability allows a remote attacker to redirect victims to arbitrary URL.

The vulnerability exists due to the lack of capability checks on the AJAX actions. A remote authenticated attacker can create a link that leads to a trusted website, however, when clicked, redirects the victim to arbitrary domain.

Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

301 Redirects: 1.1 - 2.40


CPE

External links
http://www.wordfence.com/blog/2019/12/critical-vulnerability-patched-in-301-redirects-easy-redirect...


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability