#VU25502 Path traversal


Published: 2020-03-18 | Updated: 2022-08-21

Vulnerability identifier: #VU25502

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2020-1938

CWE-ID: CWE-22

Exploitation vector: Network

Exploit availability: Yes

Vulnerable software:
Apache Tomcat
Server applications / Web servers

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to improper input validation in Apache Tomcat AJP connector. A remote attacker can send a specially crafted AJP request, include and execute arbitrary files on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Apache Tomcat: 9.0.0 - 9.0.30, 8.5.0 - 8.5.50, 7.0.0 - 7.0.99, 6.0.0 - 6.0.53


CPE

External links
http://www.jdcloud.com/cn/notice/detail/839/type/5
http://www.youtube.com/watch?v=4g1AWHLLuL8
http://github.com/Kit4y/CNVD-2020-10487-Tomcat-Ajp-lfi-Scanner


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability