#VU26756 Resource management error


Published: 2020-04-10

Vulnerability identifier: #VU26756

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-1730

CWE-ID: CWE-399

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
libssh
Universal components / Libraries / Libraries used by multiple products

Vendor: libssh

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper resource management while cleaning the AES-CTR ciphers when closing the connection. A remote attacker can initiate a connection to the client and server that supports AES-CTR ciphers and close the connection before ciphers are initialized, triggering a denial of service condition (service crash). The vulnerability affects both client and server implementations.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

libssh: 0.8.0 - 0.9.3


CPE

External links
http://www.libssh.org/security/advisories/CVE-2020-1730.txt


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability