#VU27956 Reliance on Reverse DNS Resolution for a Security-Critical Action in Apache Camel


Published: 2020-05-17

Vulnerability identifier: #VU27956

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-11971

CWE-ID: CWE-350

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Camel
Server applications / Frameworks for developing and running applications

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to perform spoofing attack.

The vulnerability exists due to Apache Camel JMX is vulnerable to DNS rebinding attack. A remote attacker can send specially crafted data to the application and perform spoofing attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache Camel: 2.25.0, 2.24.0 - 2.24.3, 2.23.0 - 2.23.4, 2.22.0 - 2.22.5, 2.21.0 - 2.21.5, 2.20.0 - 2.20.4


CPE

External links
http://www.openwall.com/lists/oss-security/2020/05/14/7
http://camel.apache.org/security/CVE-2020-11971.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability