#VU28624 Improper input validation


Published: 2020-06-04

Vulnerability identifier: #VU28624

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2019-14379

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Primavera Unifier
Client/Desktop applications / Software for system administration

Vendor: Oracle

Description

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

The vulnerability exists due to improper input validation within the Core (jackson-databind) component in Primavera Unifier. A remote non-authenticated attacker can exploit this vulnerability to execute arbitrary code.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Primavera Unifier: 16.1 - 19.12


CPE

External links
http://www.oracle.com/security-alerts/cpuoct2019.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability