#VU29544 Resource exhaustion


Published: 2020-07-07 | Updated: 2020-07-15

Vulnerability identifier: #VU29544

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-14422

CWE-ID: CWE-400

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Python
Universal components / Libraries / Scripting languages

Vendor: Python.org

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application improperly computes hash values in the IPv4Interface and IPv6Interface classes within the Lib/ipaddress.py in Python. A remote attacker can trigger resource exhaustion and perform a denial of service (DoS) attack if an application is affected by the performance of a dictionary containing IPv4Interface or IPv6Interface objects, and this attacker can cause many dictionary entries to be created.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Python: 3.8.0 - 3.8.3


CPE

External links
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00003.html
http://bugs.python.org/issue41004
http://github.com/python/cpython/pull/20956


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability