#VU30304 Use-after-free


Published: 2020-04-17 | Updated: 2020-07-17

Vulnerability identifier: #VU30304

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2020-11793

CWE-ID: CWE-416

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
WebKitGTK+
Server applications / Frameworks for developing and running applications

Vendor: WebKitGTK

Description

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

A use-after-free issue exists in WebKitGTK before 2.28.1 and WPE WebKit before 2.28.1 via crafted web content that allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash).

Mitigation
Install update from vendor's website.

Vulnerable software versions

WebKitGTK+: 2.28.0


CPE

External links
http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00008.html
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3P4YISPE5QX4YD54GDRZIH2X5RCH3QGW/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/K3MQTRC6ITFTVS5R5Z24PMJS6FXJKGRD/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UTKY2MWP6PB6TE3ZKOOMKX7HZUCQNYF6/
http://security.gentoo.org/glsa/202006-08
http://usn.ubuntu.com/4331-1/
http://webkitgtk.org/security/WSA-2020-0004.html
http://wpewebkit.org/security/WSA-2020-0004.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability