#VU31920 Buffer overflow


Published: 2020-07-27

Vulnerability identifier: #VU31920

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-15503

CWE-ID: CWE-119

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
LibRaw
Universal components / Libraries / Libraries used by multiple products

Vendor: LibRaw LLC

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error in "decoders/unpack_thumb.cpp", "postprocessing/mem_image.cpp" and u"tils/thumb_utils.cpp". A remote attacker can trigger memory corruption and cause a denial of service condition on the target system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

LibRaw: 0.8.11 - 0.19.1


CPE

External links
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00075.html
http://github.com/LibRaw/LibRaw/commit/20ad21c0d87ca80217aee47533d91e633ce1864d
http://github.com/LibRaw/LibRaw/compare/0.20-Beta3...0.20-RC1
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7HM2DS6HA4YZREI3BYGS75M6D76WMW62/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CSXAJKZ4VNDYVQULJNY4XDPWHIJDTB4P/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DNGDWTO45TU4KGND75EUUEGUMNSOYC7H/
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QCVKD7PTO7UQAVUTBHJAKBKYLPQQGAMZ/
http://www.libraw.org/news/libraw-0-20-rc1


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability