#VU32295 Buffer overflow


Published: 2015-06-15 | Updated: 2020-07-28

Vulnerability identifier: #VU32295

Vulnerability risk: Medium

CVSSv3.1: 4.6 [CVSS:3.1/CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2015-4142

CWE-ID: CWE-119

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
hostapd
Server applications / Remote access servers, VPN

Vendor: Jouni Malinen

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.

Mitigation
Install update from vendor's website.

Vulnerable software versions

hostapd: 0.5.5 - 2.4


CPE

External links
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171401.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172608.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172655.html
http://lists.opensuse.org/opensuse-updates/2015-06/msg00019.html
http://rhn.redhat.com/errata/RHSA-2015-1090.html
http://rhn.redhat.com/errata/RHSA-2015-1439.html
http://w1.fi/security/2015-3/integer-underflow-in-ap-mode-wmm-action-frame.txt
http://www.debian.org/security/2015/dsa-3397
http://www.openwall.com/lists/oss-security/2015/05/09/5
http://www.openwall.com/lists/oss-security/2015/05/31/6
http://www.securitytracker.com/id/1032625
http://www.ubuntu.com/usn/USN-2650-1
http://security.gentoo.org/glsa/201606-17


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability