#VU32958 Input validation error


Published: 2020-08-02

Vulnerability identifier: #VU32958

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2020-9802

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
WebKitGTK+
Server applications / Frameworks for developing and running applications
WPE WebKit
Server applications / Frameworks for developing and running applications

Vendor: WebKitGTK
WPE WebKit

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of user-supplied input when processing web content. A remote attacker can create a specially crafted web page, trick the victim into visiting it and execute arbitrary code on the target system.


Mitigation
Install updates from vendor's website.

Vulnerable software versions

WebKitGTK+: 2.0.0 - 2.29.2

WPE WebKit: 2.19.93 - 2.28.2


CPE

External links
http://webkitgtk.org/security/WSA-2020-0006.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability