#VU32967 Out-of-bounds read


Published: 2020-08-02

Vulnerability identifier: #VU32967

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-9894

CWE-ID: CWE-125

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
WebKitGTK+
Server applications / Frameworks for developing and running applications
WPE WebKit
Server applications / Frameworks for developing and running applications

Vendor: WebKitGTK
WPE WebKit

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to a boundary condition. A remote attacker can create a specially crafted web page, trick the victim into opening it, trigger out-of-bounds read error and read contents of memory on the system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

WebKitGTK+: 2.28.0 - 2.28.3

WPE WebKit: 2.28.0 - 2.28.3


CPE

External links
http://webkitgtk.org/security/WSA-2020-0007.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability