#VU33145 Heap-based buffer overflow in UnZip


Published: 2020-01-31 | Updated: 2020-08-03

Vulnerability identifier: #VU33145

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2014-8140

CWE-ID: CWE-122

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
UnZip
Client/Desktop applications / Software for archiving

Vendor: Info-ZIP

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in Heap-based buffer overflow in the test_compr_eb function in Info-ZIP UnZip 6.0 and earlier. A remote attacker can use a crafted zip file in the -t command argument to the unzip command. to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Update to version 6.10b.

Vulnerable software versions

UnZip: 6.0


CPE

External links
http://www.ocert.org/advisories/ocert-2014-011.html
http://www.securitytracker.com/id/1031433
http://access.redhat.com/errata/RHSA-2015:0700
http://bugzilla.redhat.com/show_bug.cgi?id=1174851


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability