#VU33148 Out-of-bounds read in UnZip


Published: 2015-11-06 | Updated: 2020-08-03

Vulnerability identifier: #VU33148

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2015-7696

CWE-ID: CWE-125

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
UnZip
Client/Desktop applications / Software for archiving

Vendor: Info-ZIP

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error in Info-ZIP UnZip 6.0. A remote attacker can perform a denial of service (heap-based buffer over-read and application crash) or possibly execute arbitrary code via a crafted password-protected ZIP archive, possibly related to an Extra-Field size value.

Mitigation
Update to version 6.10b.

Vulnerable software versions

UnZip: 6.0


CPE

External links
http://www.debian.org/security/2015/dsa-3386
http://www.openwall.com/lists/oss-security/2015/09/07/4
http://www.openwall.com/lists/oss-security/2015/09/15/6
http://www.openwall.com/lists/oss-security/2015/09/21/6
http://www.openwall.com/lists/oss-security/2015/10/11/5
http://www.securityfocus.com/bid/76863
http://www.securitytracker.com/id/1034027
http://www.ubuntu.com/usn/USN-2788-1
http://www.ubuntu.com/usn/USN-2788-2


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability