#VU45885 Improper Certificate Validation


Published: 2020-07-31 | Updated: 2020-08-21

Vulnerability identifier: #VU45885

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2020-15134

CWE-ID: CWE-295

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Faye
Web applications / Modules and components for CMS

Vendor: James Coglan

Description

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

Faye before version 1.4.0, there is a lack of certification validation in TLS handshakes. Faye uses em-http-request and faye-websocket in the Ruby version of its client. Those libraries both use the `EM::Connection#start_tls` method in EventMachine to implement the TLS handshake whenever a `wss:` URL is used for the connection. This method does not implement certificate verification by default, meaning that it does not check that the server presents a valid and trusted TLS certificate for the expected hostname. That means that any `https:` or `wss:` connection made using these libraries is vulnerable to a man-in-the-middle attack, since it does not confirm the identity of the server it is connected to. The first request a Faye client makes is always sent via normal HTTP, but later messages may be sent via WebSocket. Therefore it is vulnerable to the same problem that these underlying libraries are, and we needed both libraries to support TLS verification before Faye could claim to do the same. Your client would still be insecure if its initial HTTPS request was verified, but later WebSocket connections were not. This is fixed in Faye v1.4.0, which enables verification by default. For further background information on this issue, please see the referenced GitHub Advisory.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Faye: 1.0.0 - 1.3.0


CPE

External links
http://blog.jcoglan.com/2020/07/31/missing-tls-verification-in-faye/
http://github.com/faye/faye/security/advisories/GHSA-3q49-h8f9-9fr9


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability