#VU46737 Out-of-bounds read


Published: 2020-09-04 | Updated: 2020-09-15

Vulnerability identifier: #VU46737

Vulnerability risk: Medium

CVSSv3: 4.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:W/RC:C]

CVE-ID: CVE-2020-24977

CWE-ID: CWE-125

Exploitation vector: Network

Exploit availability: No

Vulnerable software: Libxml2
Universal components / Libraries / Libraries used by multiple products

Vendor: Gnome Development Team

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to a boundary condition within the xmlEncodeEntitiesInternal() function in libxml2/entities.c in libxml2. A remote attacker can pas specially crafted XML data to the affected application, trigger out-of-bounds read error and read contents of memory on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Note, the vulnerability was fixed in a commit 8e7c20a1 (20910-GITv2.9.10-103-g8e7c20a1).

Vulnerable software versions

Libxml2: 2.9.10

CPE

External links
http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00036.html
https://gitlab.gnome.org/GNOME/libxml2/-/issues/178
https://lists.debian.org/debian-lts-announce/2020/09/msg00009.html


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability