#VU48898 Type Confusion


Published: 2020-12-09 | Updated: 2020-12-30

Vulnerability identifier: #VU48898

Vulnerability risk: High

CVSSv3.1: 7.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-13547

CWE-ID: CWE-843

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Foxit PDF Reader for Windows
Client/Desktop applications / Office applications
Foxit PDF Editor (formerly Foxit PhantomPDF)
Client/Desktop applications / Office applications

Vendor: Foxit Software Inc.

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a type confusion error, when an incorrect argument was passed to the app.media.openPlayer function defined in PDF JavaScript API. A remote attacker can create specially crafted PDF file, trick the victim into opening it, trigger a type confusion error and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Reader for Windows: 9.0 - 10.1.0.37527

Foxit PDF Editor (formerly Foxit PhantomPDF): 10.0.0.35798 - 10.1.0.37527, 9.0 - 9.7.4.29600


CPE

External links
http://www.foxitsoftware.com/support/security-bulletins.html


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability