#VU49547 OS Command Injection


Published: 2021-01-14

Vulnerability identifier: #VU49547

Vulnerability risk: Low

CVSSv3.1: 6.8 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-0218

CWE-ID: CWE-78

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
Juniper Junos OS
Operating systems & Components / Operating system

Vendor:

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to improper input validation in the license-check daemon. A local user can execute the request system license update CLI command and execute arbitrary OS commands with elevated privileges.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Juniper Junos OS: before 17.3R3-S9, 17.4R2-S12, 17.4R3-S3, 18.1R3-S11, 18.2R3-S6, 18.3R3-S4, 18.4R3-S6, 19.1R1-S6, 19.1R2-S2, 19.1R3-S3, 19.2R3-S1, 19.3R2-S5, 19.3R3, 19.4R2-S2, 19.4R3, 20.1R1-S4, 20.1R2, 20.2R1-S2, 20.2R2, 20.3R1

CPE

External links
https://kb.juniper.net/InfoCenter/index?page=content&id=JSA11108&cat=SIRT_1&actp=LIST


Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability