#VU49550 Execution with unnecessary privileges


Published: 2021-01-15

Vulnerability identifier: #VU49550

Vulnerability risk: Low

CVSSv3.1: 6.8 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-0223

CWE-ID: CWE-250

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
Juniper Junos OS
Operating systems & Components / Operating system

Vendor:

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to application binary telnetd.real has a setuid bit. A local low-privileged user can run the affected binary and execute arbitrary code on the system with root privileges.

Mitigation

Install updates from vendor's website.

This issue affects Juniper Networks Junos OS:

  • all versions prior to 15.1R7-S9;
  • 17.3 versions prior to 17.3R3-S11;
  • 17.4 versions prior to 17.4R2-S12, 17.4R3-S3;
  • 18.1 versions prior to 18.1R3-S11;
  • 18.2 versions prior to 18.2R3-S6;
  • 18.3 versions prior to 18.3R3-S4;
  • 18.4 versions prior to 18.4R2-S7, 18.4R3-S6;
  • 19.1 versions prior to 19.1R2-S2, 19.1R3-S4;
  • 19.2 versions prior to 19.2R1-S6, 19.2R3-S1;
  • 19.3 versions prior to 19.3R3-S1;
  • 19.4 versions prior to 19.4R2-S2, 19.4R3-S1;
  • 20.1 versions prior to 20.1R1-S4, 20.1R2;
  • 20.2 versions prior to 20.2R2.

Vulnerable software versions

Juniper Junos OS: before 15.1R7-S9, 17.3R3-S11, 17.4R2-S12, 17.4R3-S3, 18.1R3-S11, 18.2R3-S6, 18.3R3-S4, 18.4R2-S7, 18.4R3-S6, 19.1R2-S2, 19.1R3-S4, 19.2R1-S6, 19.2R3-S1, 19.3R3-S1, 19.4R2-S2, 19.4R3-S1, 20.1R1-S4, 20.1R2, 20.2R2, 20.3R1

CPE

External links
https://kb.juniper.net/InfoCenter/index?page=content&id=JSA11114&cat=SIRT_1&actp=LIST


Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability