#VU50234 Type Confusion


Published: 2021-02-02 | Updated: 2022-05-04

Vulnerability identifier: #VU50234

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2021-1789

CWE-ID: CWE-843

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
WPE WebKit
Server applications / Frameworks for developing and running applications
WebKitGTK+
Server applications / Frameworks for developing and running applications

Vendor: WPE WebKit
WebKitGTK

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a type confusion error in WebKit. A remote attacker can trick the victim to open a specially crafted website, trigger a type confusion error and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

WPE WebKit: 2.19.93 - 2.31.90

WebKitGTK+: 2.0.0 - 2.31.90


CPE

External links
http://support.apple.com/en-us/HT212147


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability