#VU50606 Incorrect Regular Expression in Ruby on Rails


Published: 2021-02-11

Vulnerability identifier: #VU50606

Vulnerability risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-22880

CWE-ID: CWE-185

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Ruby on Rails
Universal components / Libraries / Scripting languages

Vendor: Rails

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to incorrect regular expression for money processing format in the PostgreSQL adapter. A remote attacker can pass specially crafted input to the application and perform a regular expression denial of service (ReDOS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Ruby on Rails: 5.0.0 - 6.1.2


External links
http://github.com/rails/rails/releases/tag/v6.1.2.1
http://github.com/rails/rails/releases/tag/v6.0.3.5
http://github.com/rails/rails/releases/tag/v5.2.4.5


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability