#VU51943 Stack-based buffer overflow


Published: 2021-04-06

Vulnerability identifier: #VU51943

Vulnerability risk: Medium

CVSSv3.1: 5.7 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-17656

CWE-ID: CWE-121

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
FortiProxy
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor: Fortinet, Inc

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error when processing HTTP PUT requests in FortiProxy HTTPD daemon. A remote authenticated user can send a specially crafted HTTP PUT request, trigger stack-based buffer overflow and crash the daemon.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

FortiProxy: 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 2.0.0, 2.0.1

CPE

External links
https://www.fortiguard.com/psirt/FG-IR-21-007


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability