#VU52831 Resource exhaustion


Published: 2021-05-04

Vulnerability identifier: #VU52831

Vulnerability risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-21306

CWE-ID: CWE-400

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
marked
Web applications / Modules and components for CMS

Vendor: Monica

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly control consumption of internal resources. A remote attacker can trigger resource exhaustion and perform a denial of service (DoS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

marked: 1.1.1, 1.1.2, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 2.0.0

CPE

External links
https://github.com/markedjs/marked/commit/7293251c438e3ee968970f7609f1a27f9007bccd
https://github.com/markedjs/marked/issues/1927
https://github.com/markedjs/marked/pull/1864
https://github.com/markedjs/marked/security/advisories/GHSA-4r62-v4vq-hr96
https://www.npmjs.com/package/marked


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability