#VU54019 Insufficient verification of data authenticity


Published: 2021-06-10

Vulnerability identifier: #VU54019

Vulnerability risk: Medium

CVSSv3.1: 7.1 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-33712

CWE-ID: CWE-345

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Mendix SAML Module
Client/Desktop applications / Other client software

Vendor:

Description

The vulnerability allows a remote attacker to escalate privileges on the system.

The vulnerability exists due to the affected software does not properly check various restrictions and validations imposed by an identity provider. A remote authenticated attacker can gain elevated privileges on the target system. 

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Mendix SAML Module: before 2.1.2

CPE

External links
https://cert-portal.siemens.com/productcert/pdf/ssa-522654.pdf
https://us-cert.cisa.gov/ics/advisories/icsa-21-159-07


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability