#VU54683 Security restrictions bypass in Mozilla Firefox


Published: 2021-07-13

Vulnerability identifier: #VU54683

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-29974

CWE-ID: CWE-264

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Mozilla Firefox
Client/Desktop applications / Web browsers

Vendor: Mozilla

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to application allows to override HSTS error, when network partitioning was enabled. As a result of Enhanced Tracking Protection settings, a TLS error page would allow the user to override an error on a domain which had specified HTTP Strict Transport Security.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Mozilla Firefox: 80.0 - 89.0.2


CPE

External links
http://www.mozilla.org/en-US/security/advisories/mfsa2021-28/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability