#VU54775 Use of cryptographically weak pseudo-random number generator (PRNG)


Published: 2021-07-13

Vulnerability identifier: #VU54775

Vulnerability risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-26091

CWE-ID: CWE-338

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Fortinet FortiMail
Server applications / IDS/IPS systems, Firewalls and proxy servers

Vendor: Fortinet, Inc

Description

The vulnerability allows a remote attacker to reset credentials of other users.

The vulnerability exists due to usage of weak pseudo-random number generator in the authenticator of FortiMail Identity Based Encryption service. A remote attacker can infer parts of users authentication tokens and reset their credentials.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Fortinet FortiMail: 6.2.0 - 6.4.4


CPE

External links
http://www.fortiguard.com/psirt/FG-IR-21-031


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability