#VU55058 Improper input validation


Published: 2021-07-20 | Updated: 2021-07-22

Vulnerability identifier: #VU55058

Vulnerability risk: Low

CVSSv3.1: 3.8 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-2369

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Oracle GraalVM Enterprise Edition
Server applications / Virtualization software

Vendor: Oracle

Description

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The vulnerability exists due to improper input validation within the Library component in Oracle GraalVM Enterprise Edition. A remote non-authenticated attacker can exploit this vulnerability to manipulate data.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Oracle GraalVM Enterprise Edition: 20.3.2, 21.1.0

CPE

External links
https://www.oracle.com/security-alerts/cpujul2021.html


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability