#VU56931 Buffer overflow


Published: 2021-09-29

Vulnerability identifier: #VU56931

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-30129

CWE-ID: CWE-119

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Mina SSHD
Server applications / Remote management servers, RDP, SSH

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error in the sshd-core of Apache Mina SSHD. A remote attacker can send specially crafted requests to the server, trigger buffer overflow and perform a denial of service (DoS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache Mina SSHD: 2.0.0 - 2.6.0


CPE

External links
http://lists.apache.org/thread.html/r6d4f78e192a0c8eabd671a018da464024642980ecd24096bde6db36f%40%3Cusers.mina.apache.org%3E
http://lists.apache.org/thread.html/r6d4f78e192a0c8eabd671a018da464024642980ecd24096bde6db36f@%3Cusers.mina.apache.org%3E
http://lists.apache.org/thread.html/red01829efa2a8c893c4baff4f23c9312bd938543a9b8658e172b853b@%3Cannounce.apache.org%3E
http://www.openwall.com/lists/oss-security/2021/07/12/1
http://github.com/advisories/GHSA-9279-7hph-r3xw


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability