#VU57229 Memory corruption in Foxit PDF Reader for Windows and Foxit PDF Editor (formerly Foxit PhantomPDF)


Published: 2021-10-12

Vulnerability identifier: #VU57229

Vulnerability risk: High

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-119

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Foxit PDF Reader for Windows
Client/Desktop applications / Office applications
Foxit PDF Editor (formerly Foxit PhantomPDF)
Client/Desktop applications / Office applications

Vendor: Foxit Software Inc.

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to multiple boundary errors when processing PDF files. A remote attacker can create a specially crafted PDF document, trick the victim into opening it, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

The vulnerability has been assigned the following identifiers: ZDI-CAN-14273, ZDI-CAN-14395/CNVD-C-2021-247436, ZDI-CAN-14355, ZDI-CAN-14356, ZDI-CAN-14357, ZDI-CAN-14358, ZDI-CAN-14359, ZDI-CAN-14360, ZDI-CAN-14361, ZDI-CAN-14362, ZDI-CAN-14363, ZDI-CAN-14364, ZDI-CAN-14365, ZDI-CAN-14366, ZDI-CAN-14367, ZDI-CAN-14368.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Reader for Windows: 9.0 - 11.0.1.49938

Foxit PDF Editor (formerly Foxit PhantomPDF): 11.0.0.0510 - 11.0.1.49938, 10.0.0.35798 - 10.1.5.37672, 9.0 - 9.7.5.29616


CPE

External links
http://www.foxitsoftware.com/support/security-bulletins.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability