#VU57231 Stack overflow in Foxit PDF Reader for Windows and Foxit PDF Editor (formerly Foxit PhantomPDF)


Published: 2021-10-12

Vulnerability identifier: #VU57231

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-121

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Foxit PDF Reader for Windows
Client/Desktop applications / Office applications
Foxit PDF Editor (formerly Foxit PhantomPDF)
Client/Desktop applications / Office applications

Vendor: Foxit Software Inc.

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition when handling JavaScript in PDF files. A remote attacker can create a specially crafted PDF file, trick the victim into opening it, trigger the stack overflow and crash the application.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Foxit PDF Reader for Windows: 9.0 - 11.0.1.49938

Foxit PDF Editor (formerly Foxit PhantomPDF): 11.0.0.0510 - 11.0.1.49938, 10.0.0.35798 - 10.1.5.37672, 9.0 - 9.7.5.29616


CPE

External links
http://www.foxitsoftware.com/support/security-bulletins.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability