#VU57444 Heap-based buffer overflow


Published: 2021-10-19 | Updated: 2021-10-21

Vulnerability identifier: #VU57444

Vulnerability risk: High

CVSSv3.1: 7.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-37981

CWE-ID: CWE-122

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Google Chromium
Client/Desktop applications / Web browsers

Vendor: Google

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing untrusted HTML content in Skia. A remote attacker can create a specially crafted web page, trick the victim into opening it, trigger a heap-based buffer overflow and execute arbitrary code on the target system.

Mitigation
Update to version 95.0.4638.54.

Vulnerable software versions

Google Chromium: 95.0.4638.0 - 95.0.4638.53


CPE

External links
http://chromereleases.googleblog.com/2021/10/stable-channel-update-for-desktop_19.html
http://crbug.com/1246631
http://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-37981


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability